EGEsoll - сборник решений задач из ЕГЭ

Задача 7 досрок

Напишите программу, которая перебирает целые числа, большие 700 000, в порядке возрастания и ищет среди них такие, у которых есть натуральный делитель, оканчивающийся на цифру 7 и не равный ни самому числу, ни числу 7. Выведите первые пять найденных чисел и для каждого -  соответствующий наименьший делитель, оканчивающийся на цифру 7, не равный ни самому числу, ни числу 7.
Формат вывода: для каждого из пяти найденных чисел в отдельной строке сначала выводится само число, затем - значение наименьшего делителя, оканчивающегося на цифру 7, не равного ни самому числу, ни числу 7.
Строки выводятся в порядке возрастания найденных чисел.
Количество строк в таблице для ответа избыточно.

Досрочный вариант 2026 - КЕГЭ

Добавлено: 18.04.26 09:17

Перейти к решению

Решение

Решение на Python:

from math import isqrt

cnt = 0
for x in range(700_000, 1_000_000):
    d = []
    root = isqrt(x)
    for k in range(2, root + 1):
        if x % k == 0:
            d.append(k)
            d.append(x // k)
    us = [el for el in d if str(abs(el))[-1] == "7" and el != 7 and el != x]
    if any(us):
        print(x, min(us))
        cnt += 1
    if cnt == 5:
        break

Ответ:

700002 27
700003 37
700005 6087
700007 77
700008 29167

Автор - rubygem17

Объяснение

None

Назад